The Web never forgets: Persistent tracking mechanisms in the wild

July 29th, 2014

4-20 in Santa Monica Mountains

April 25th, 2014


Sullivan Ridge and Backbone Trail Loop

( Sullivan Ridge Fire road, Mulholland road, Fireroad 30 to The Hub, Backbone trail, J-Drop & back to Sullivan Ridge fire road )

My first GoPro cut!

The Presenter Manifesto : 8 Distinctions of a World Class Presenter…

October 15th, 2013

The Presenter Manifesto : 8 Distinctions of a World Class Presenter…

October 15th, 2013

Mikrotik + ClouldFlare = DynDNS

October 6th, 2013
At times I want to reach my home computer, so I had a dynamic DNS service that keeps a DNS record ( like myhomeip.dyndns.org) in sync with your home IP address that changes from time to time.

I got fed up with free service from DynDNS: your record will disappear in 30 days unless you login into their site and "confirm" it. DynDNS annoys you on purpose, so you buy their "pro" service. I do not like being annoyed, and I do not see a point of paying for DynDNS service -- their value proposition is weak, as anyone can create a script that updates DNS records.

I have a website that is protected by ClouldFlare service. ClouldFlare offers an API that can be used to update DNS records, so I wrote a script for Mikrotik RouterOS that does just that.



Note that you need RouterOS v6 ( as fetch command supports https only since version 6.0rc12


##############Script Settings##################

:local CFemail "clouldflare email login "
:local CFtkn "api access token"
:local CFzone "clouldflare website, example: example.com"
:local CFid "dns record id, available via rec_load_all API call, example: 12345"
:local CFtype "A"
:local CFttl "300"
:local CFservicemode "0"
:local CFDomain "FQDN DNS record that you will be updating, example: myhomeip.exmaple.com"

############## Build CF API Url ################
:local CFurl "https://www.cloudflare.com/api_json.html\3F"
:set CFurl ($CFurl . "a=rec_edit&tkn=$CFtkn&id=$CFid");
:set CFurl ($CFurl . "&email=$CFemail&z=$CFzone&type=$CFtype");
:set CFurl ($CFurl . "&name=$CFDomain&service_mode=$CFservicemode&ttl=$CFttl");

:local WANInter "name of the outing network interface on mikrotik router, example: ether1-gateway"

###############################################

:local IpCurrent [/ip address get [find interface=$WANInter] address];
:for i from=( [:len $IpCurrent] - 1) to=0 do={
:if ( [:pick $IpCurrent $i] = "/") do={
:local NewIP [:pick $IpCurrent 0 $i];
:if ([:resolve $CFDomain] != $NewIP) do={
:log info "Will update: $NewIP"
/tool fetch mode=https url="$CFurl&content=$NewIP" keep-result=no
:log info "CF Update: $CFDomain - $NewIP"
}
}
}





http://www.cloudflare.com/docs/client-api.html
http://wiki.mikrotik.com/wiki/Manual:Scripting

How cognac is made | Как делают французский коньяк

October 6th, 2013
Originally posted by sergeydolya at Как делают французский коньяк


Программа поездки напоминала что-то среднее между головокружительным алкогольным пике и марафонским забегом. Каждый день у нас было минимум два коньячных дома: дегустации начинались с самого утра, сменялись обедом или ужином под вино, а затем продолжались вновь.

Однако, вопреки обстоятельствам, мне удалось-таки сделать то, что не получилось в прошлую поездку: сфотографировать весь процесс производства коньяка от А до Я…



Еще один коньячный дом, который мы посетили с дружественным дегустационным визитом - Pierre Ferrand. В ходе знакомства с хозяином дома выяснили любопытную вещь: процесс производства коньяка контролируется специальным надзорным государственным органом. Поэтому идеи вроде "написать на бутылке одно, а налить другое" не возможны в принципе. В качестве иллюстрации нам рассказали историю, как одного экспериментатора, насыпавшего в бочку опилок для усиления вкуса, посадили на пять месяцев в тюрьму и запретили в будущем заниматься коньячным делом:

3.

С другой стороны сами производители стараются держать марку. Например, по регламенту ХО не может быть моложе шести лет, но по факту все дома устанавливают эту планку еще выше - десять-пятнадцать:

4.

Еще в Pierre Ferrand нам показали разные хранилища - сухие и влажные. Говоря в двух словах, специфика складов такова, что во влажном с годами испаряются спирты, а в сухом - вода. Продуманная схема хранения в том и другом скаладах позволяет регулировать крепость готового напитка:

5.

Еще в коньячных хранилищах специально разводят пауков. Они борются с паразитами, которые грызут бочки:

6.

7.

Хозяин дома Pierre Ferrand:

8.

А это De Luze - огромное хозяйство. На их производстве полный цикл, кроме того, крупные дома покупают у De Luze коньячные спирты для своих блендов:

9.

Итак, все начинается с винограда. Одним из основных сортов для производства коньяка является Уньи блан:

10.

11.

Собирают виноград специальными аппаратами:

12.

Машинка едет по винограднику, лоза попадает в сборник, который сбивает урожай и отправляет его по транспортеру вверх в баки:

13.

Внутри полный хай-тек: планшет, джойстик:

14.

Собранный виноград привозят в первый цех и сваливают в специальную ванну:

15.

Из приёмника он попадает в давилки, где получают виноградный сок. Использовать давилки, которые перемалывают косточки, запрещено законом:

16.

Пульт управления:

17.

Затем сок поступает в огромнейшие чаны, где происходит процесс ферментации и виноградный сок превращается в вино:

18.

Вино готово. Теперь оно направляется в цех дистилляции, где получают коньячный спирт.

Процесс элементарен: вино вываривается, и спирт по змеевику собирается в специальные емкости. Интересный момент: у спирта есть условные "голова" и "хвост" - первые и последние литры перегона. Некоторые дома, например предыдущий Pierre Ferrand, не используют эти части, а только "сердце" - основную часть:

19.

Схематичный макет аппарата:

20.

Дистилляция проходит в два этапа: первый перегон позволяет получить базовый дистиллят крепостью около 30%. Затем он перегоняется еще раз. Именно вторая фракция, крепостью около 70% и идёт на дальнейшую выдержку в дубовых бочках:

21.

Даже бочки De Luze изготавливает самостоятельно, около 150 в год. Репортаж с бондарного производства я выкладывал в позапрошлом году:

22.

Важный этап - обжигание бочки:

23.

Цех, где De Luze делает бленды для своего коньяка - смешивает разные спирты:

24.

Не менее впечатляюще выглядит и хранилище:

25.

А вот бочка коньячного спирта специально для Remy Martin:

26.

Само собой, здесь тоже есть свой "рай":

27.

На производстве De Luze я, наконец, увидел, как разливают коньяк по бутылкам:

28.

Коньяк - не пиво, поэтому линия разлива небольшая, многое происходит вручную. Сперва чистые и пустые бутылки устанавливают на конвейр:

29.

Вереница бутылок попадает в "карусель", где, собственно, и происходит разлив. Специалист внимательно контролирует процесс:

30.

Тут же накручиваются пробки:

31.

Следующий этап - наклейка этикеток и акцизов:

32.

33.

Заметил, что у станка открывается крышка и решил, что лучше просунуть туда камеру, чем снимать через стекло. Стоило ее открыть, как линия сразу стала и бутылки начали скапливаться. К счастью, меня не засекли:

34.

В самом конце бутылки еще раз проверяют вручную:

35.

И вот результат. Признаюсь, такого мягкого коньяка я еще не пробовал:

36.

Под конец экскурсии мы оставили отзывы. Кое-кто из нашей команды соригинальничал:

37.

В следующем посте я расскажу за сколько отошла самая дорогая бутылка коньяка на аукционе!

Stay Tuned!



Я в других социальных сетях:


Уголок партнеров блога

Все мои фотографии лежат на www.4sync.com. 4Sync не меняет название файлов и предоставляет бесплатно 15 Гб

Paul Smith Underwear

October 5th, 2013
Originally posted by drugoi at Paul Smith Underwear




www.youtube.com/embed/8q9O9r4GTNA

Реклама мужского нижнего белья марки Paul Smith.
Absolutely Unbelievable.
Слэклайнеры Антуан Моневиль и Танкред Меле.
Респектище, вот это работа!

Bad Connections Dog Google’s Mountain View Wi-Fi Network – Slashdot

August 10th, 2013
Interesting post on slashdot explaining why wifi (in general) sucks as a networking technology

Bad Connections Dog Google’s Mountain View Wi-Fi Network – Slashdot

August 10th, 2013
Interesting post on slashdot explaining why wifi (in general) sucks as a networking technology

WSJ’s Wireless Savings Calculator – WSJ.com

August 10th, 2013
very nice tool for comparing plans from different wireless providers